A Few Questions About 4.0

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

A Few Questions About 4.0

Gregg D Bolinger
I am sorry if this has been asked. I search both the archives and the
Tapestry site and couldn't find the answers.

1.  Is there a scheduled realese date for Tapestry 4.0 Beta1+
2.  Is there a 3.0.x - 4.0 migration guide in the works?
3.  If I were to start using 4.0 Alpha (not in production of course),
is it likely to change dramatically?

Thanks for any information.

Gregg Bolinger

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: A Few Questions About 4.0

Howard Lewis Ship
On 5/6/05, Gregg D Bolinger <[hidden email]> wrote:
>
> I am sorry if this has been asked. I search both the archives and the
> Tapestry site and couldn't find the answers.
>
> 1. Is there a scheduled realese date for Tapestry 4.0 Beta1+



I'm finishing up the Porlet support right now. Once I have that finished,
I'll be looking to draw a line on functionality and move to a beta. Look for
the first beta in June.

2. Is there a 3.0.x - 4.0 migration guide in the works?



There's the start of one. I'm going to carefully re-work the Virtual Library
and use that as the basis of a realistic guide.

3. If I were to start using 4.0 Alpha (not in production of course),
> is it likely to change dramatically?



I don't think so; some internals may shift, and there's a couple of minor
tweaks yet for the DTDs, possibly.

Thanks for any information.
>
> Gregg Bolinger
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Howard M. Lewis Ship
Independent J2EE / Open-Source Java Consultant
Creator, Jakarta Tapestry
Creator, Jakarta HiveMind

Professional Tapestry training, mentoring, support
and project work. http://howardlewisship.com
Reply | Threaded
Open this post in threaded view
|

AW: A Few Questions About 4.0

Ralf Edmund Stranzenbach
As a newbie on Tapestry i'm currently working on porting a sample
application from Struts to Tapestry.

Does it already make sense to start development using Tapestry 4.0 ?

Mit freundlichen Gr??en,
Ralf Edmund Stranzenbach



-----Urspr?ngliche Nachricht-----
Von: Howard Lewis Ship [mailto:[hidden email]]
Gesendet: Freitag, 6. Mai 2005 22:03
An: Tapestry users; Gregg D Bolinger
Betreff: Re: A Few Questions About 4.0


On 5/6/05, Gregg D Bolinger <[hidden email]> wrote:
>
> I am sorry if this has been asked. I search both the archives and the
> Tapestry site and couldn't find the answers.
>
> 1. Is there a scheduled realese date for Tapestry 4.0 Beta1+



I'm finishing up the Porlet support right now. Once I have that finished,
I'll be looking to draw a line on functionality and move to a beta. Look for
the first beta in June.

2. Is there a 3.0.x - 4.0 migration guide in the works?



There's the start of one. I'm going to carefully re-work the Virtual Library
and use that as the basis of a realistic guide.

3. If I were to start using 4.0 Alpha (not in production of course),
> is it likely to change dramatically?



I don't think so; some internals may shift, and there's a couple of minor
tweaks yet for the DTDs, possibly.

Thanks for any information.
>
> Gregg Bolinger
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Howard M. Lewis Ship
Independent J2EE / Open-Source Java Consultant
Creator, Jakarta Tapestry
Creator, Jakarta HiveMind

Professional Tapestry training, mentoring, support
and project work. http://howardlewisship.com


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: A Few Questions About 4.0

Erik Hatcher

On May 7, 2005, at 4:34 AM, Ralf E. Stranzenbach wrote:

> As a newbie on Tapestry i'm currently working on porting a sample
> application from Struts to Tapestry.
>
> Does it already make sense to start development using Tapestry 4.0 ?

I think so.  I'm using CVS HEAD of 4.0 with no problems.  The more  
folks that use it the better 4.0 will be when it is officially  
released :)

     Erik


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

JSR 168 support

Christian-2
In reply to this post by Howard Lewis Ship
Howard Lewis Ship wrote:

>
>I'm finishing up the Porlet support right now. Once I have that finished,
>I'll be looking to draw a line on functionality and move to a beta. Look for
>the first beta in June.
>  
>
sorry for thread kidnapping: Howard, which portal/portlet container did
you use for the JSR 168 development?
Any suggestions on "tapestry friendlines"?



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: JSR 168 support

Howard Lewis Ship
Most of my testing has been on eXo ... but the whole point of JSR-168
is that it should not matter. I'll be testing with Jetspeed and,
likely, Liferay, shortly.  I'm still ironing out the last few
annoyances.

On 5/7/05, Christian <[hidden email]> wrote:

> Howard Lewis Ship wrote:
>
> >
> >I'm finishing up the Porlet support right now. Once I have that finished,
> >I'll be looking to draw a line on functionality and move to a beta. Look for
> >the first beta in June.
> >
> >
> sorry for thread kidnapping: Howard, which portal/portlet container did
> you use for the JSR 168 development?
> Any suggestions on "tapestry friendlines"?
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Howard M. Lewis Ship
Independent J2EE / Open-Source Java Consultant
Creator, Jakarta Tapestry
Creator, Jakarta HiveMind

Professional Tapestry training, mentoring, support
and project work.  http://howardlewisship.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: A Few Questions About 4.0

Gregg D Bolinger
In reply to this post by Erik Hatcher
Will 3.0 apps work with 4.0 without any changes other than
replacing/including necessary JAR files?  Can you go by the 3.0 docs
and still produce a 4.0 app?  All I have is the online docs and TiA.
;)

Gregg

On 5/7/05, Erik Hatcher <[hidden email]> wrote:

>
> On May 7, 2005, at 4:34 AM, Ralf E. Stranzenbach wrote:
>
> > As a newbie on Tapestry i'm currently working on porting a sample
> > application from Struts to Tapestry.
> >
> > Does it already make sense to start development using Tapestry 4.0 ?
>
> I think so.  I'm using CVS HEAD of 4.0 with no problems.  The more
> folks that use it the better 4.0 will be when it is officially
> released :)
>
>      Erik
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: A Few Questions About 4.0

Howard Lewis Ship
That's the goal, but I believe we'll only make it about 90% of the way
there. For a few select things (usually application-wide, not specific
to a page or component) there will be incompatible API changes -- but
again, pages and components should continue to work as they did in the
past, even when using the 3.0 DTDs.

On 5/7/05, Gregg D Bolinger <[hidden email]> wrote:

> Will 3.0 apps work with 4.0 without any changes other than
> replacing/including necessary JAR files?  Can you go by the 3.0 docs
> and still produce a 4.0 app?  All I have is the online docs and TiA.
> ;)
>
> Gregg
>
> On 5/7/05, Erik Hatcher <[hidden email]> wrote:
> >
> > On May 7, 2005, at 4:34 AM, Ralf E. Stranzenbach wrote:
> >
> > > As a newbie on Tapestry i'm currently working on porting a sample
> > > application from Struts to Tapestry.
> > >
> > > Does it already make sense to start development using Tapestry 4.0 ?
> >
> > I think so.  I'm using CVS HEAD of 4.0 with no problems.  The more
> > folks that use it the better 4.0 will be when it is officially
> > released :)
> >
> >      Erik
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
Howard M. Lewis Ship
Independent J2EE / Open-Source Java Consultant
Creator, Jakarta Tapestry
Creator, Jakarta HiveMind

Professional Tapestry training, mentoring, support
and project work.  http://howardlewisship.com

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: A Few Questions About 4.0

Erik Hatcher
In reply to this post by Gregg D Bolinger

On May 7, 2005, at 5:01 PM, Gregg D Bolinger wrote:

> Will 3.0 apps work with 4.0 without any changes other than
> replacing/including necessary JAR files?  Can you go by the 3.0 docs
> and still produce a 4.0 app?  All I have is the online docs and TiA.
> ;)

I've fought back on a few changes that would have broken 3.0 apps in  
4.0, and Howard has restored the API that was removed.  I'm not quite  
sure if it'll work that cleanly though - I believe there are some  
changes that are required but I'm not sure what they are at the moment.

I'm building a new application from scratch in 4.0, so I haven't  
tried it myself.  I'll try one of my 3.0 apps in a few days and see  
though.

One way to try this is to replace all Tapestry JAR's (and  
dependencies) in the binary 3.0 Workbench webapp with the 4.0 ones  
and see what happens.  I haven't tried this either.

Feedback from users would be very helpful in this regard, in either  
fixing whatever we can to keep as much compatibility as possible, or  
at least noting it.  I personally juggle too many variables and have  
not noted every little change I've made regarding 4.0.

     Erik


>
> Gregg
>
> On 5/7/05, Erik Hatcher <[hidden email]> wrote:
>
>>
>> On May 7, 2005, at 4:34 AM, Ralf E. Stranzenbach wrote:
>>
>>
>>> As a newbie on Tapestry i'm currently working on porting a sample
>>> application from Struts to Tapestry.
>>>
>>> Does it already make sense to start development using Tapestry 4.0 ?
>>>
>>
>> I think so.  I'm using CVS HEAD of 4.0 with no problems.  The more
>> folks that use it the better 4.0 will be when it is officially
>> released :)
>>
>>      Erik
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: tapestry-user-
>> [hidden email]
>>
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: A Few Questions About 4.0

Matt Raible
In reply to this post by Erik Hatcher

On May 7, 2005, at 4:09 AM, Erik Hatcher wrote:

>
> On May 7, 2005, at 4:34 AM, Ralf E. Stranzenbach wrote:
>
>> As a newbie on Tapestry i'm currently working on porting a sample
>> application from Struts to Tapestry.
>>
>> Does it already make sense to start development using Tapestry 4.0 ?
>
> I think so.  I'm using CVS HEAD of 4.0 with no problems.  The more
> folks that use it the better 4.0 will be when it is officially
> released :)

I'm willing to upgrade AppFuse and Equinox to 4.0.  For AppFuse, this
will require the a couple of features: friendly URLs and a global
properties file.  I believe both of these are in 4.0 - right?

Matt


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: AW: A Few Questions About 4.0

Gregg D Bolinger
In reply to this post by Howard Lewis Ship
Thanks Howard.  I do admire you for taking 4.0 in the direction you
are headed with it.  My beef was due to a lack of understanding on the
4.0 roadmap and your goals for tapestry.  It takes balls to say "Hey,
some things are going to break, but it will be better in the long
run".  It's something Sun needs to do with Java one of these days.
Backwards compatibility can really hinder progress.

Gregg Bolinger


On 5/7/05, Howard Lewis Ship <[hidden email]> wrote:

> That's the goal, but I believe we'll only make it about 90% of the way
> there. For a few select things (usually application-wide, not specific
> to a page or component) there will be incompatible API changes -- but
> again, pages and components should continue to work as they did in the
> past, even when using the 3.0 DTDs.
>
> On 5/7/05, Gregg D Bolinger <[hidden email]> wrote:
> > Will 3.0 apps work with 4.0 without any changes other than
> > replacing/including necessary JAR files?  Can you go by the 3.0 docs
> > and still produce a 4.0 app?  All I have is the online docs and TiA.
> > ;)
> >
> > Gregg
> >
> > On 5/7/05, Erik Hatcher <[hidden email]> wrote:
> > >
> > > On May 7, 2005, at 4:34 AM, Ralf E. Stranzenbach wrote:
> > >
> > > > As a newbie on Tapestry i'm currently working on porting a sample
> > > > application from Struts to Tapestry.
> > > >
> > > > Does it already make sense to start development using Tapestry 4.0 ?
> > >
> > > I think so.  I'm using CVS HEAD of 4.0 with no problems.  The more
> > > folks that use it the better 4.0 will be when it is officially
> > > released :)
> > >
> > >      Erik
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> --
> Howard M. Lewis Ship
> Independent J2EE / Open-Source Java Consultant
> Creator, Jakarta Tapestry
> Creator, Jakarta HiveMind
>
> Professional Tapestry training, mentoring, support
> and project work.  http://howardlewisship.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]