About quickstart and TAP5-2579

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

About quickstart and TAP5-2579

pico.dev
Hi,

The quickstart project has the following issue open
https://issues.apache.org/jira/browse/TAP5-2579.

Running the quickstart as in comment
https://issues.apache.org/jira/browse/TAP5-2579?focusedCommentId=16770261#comment-16770261
ends with BUILD FAILURE. After fixing BUILD FAILURE error "./gradlew
tasks" fails with "Plugin with id 'gretty' not found." message.
Running "mvn jetty:run" fails with "Could not find artifact
javax.servlet:servlet-api:jar:3.0.1 in jboss
(http://repository.jboss.org/nexus/content/groups/public/)" message.

Also in my initial idea for update quickstart could be:

* Use Spring Boot instead Gretty?
* Use log4j 2 instead slf4j and logback?
* Provide some simple unit and integration test examples?
* Use more new Gradle version (ideally latest) instead of taking
Tapestry Gradle build version?

I could spend some time updating quickstart and provide a patch. It
seems good to you?

Regards,
pd

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: About quickstart and TAP5-2579

Thiago H de Paula Figueiredo
Yes! Please do it.

On Mon, Feb 18, 2019 at 6:20 PM pico.dev <[hidden email]> wrote:

> Hi,
>
> The quickstart project has the following issue open
> https://issues.apache.org/jira/browse/TAP5-2579.
>
> Running the quickstart as in comment
>
> https://issues.apache.org/jira/browse/TAP5-2579?focusedCommentId=16770261#comment-16770261
> ends with BUILD FAILURE. After fixing BUILD FAILURE error "./gradlew
> tasks" fails with "Plugin with id 'gretty' not found." message.
> Running "mvn jetty:run" fails with "Could not find artifact
> javax.servlet:servlet-api:jar:3.0.1 in jboss
> (http://repository.jboss.org/nexus/content/groups/public/)" message.
>
> Also in my initial idea for update quickstart could be:
>
> * Use Spring Boot instead Gretty?
> * Use log4j 2 instead slf4j and logback?
> * Provide some simple unit and integration test examples?
> * Use more new Gradle version (ideally latest) instead of taking
> Tapestry Gradle build version?
>
> I could spend some time updating quickstart and provide a patch. It
> seems good to you?
>
> Regards,
> pd
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

--
Thiago
Reply | Threaded
Open this post in threaded view
|

Re: About quickstart and TAP5-2579

pico.dev
Great! I will be back with a patch in some days.

El mié., 20 feb. 2019 a las 14:33, Thiago H. de Paula Figueiredo
(<[hidden email]>) escribió:

>
> Yes! Please do it.
>
> On Mon, Feb 18, 2019 at 6:20 PM pico.dev <[hidden email]> wrote:
>
> > Hi,
> >
> > The quickstart project has the following issue open
> > https://issues.apache.org/jira/browse/TAP5-2579.
> >
> > Running the quickstart as in comment
> >
> > https://issues.apache.org/jira/browse/TAP5-2579?focusedCommentId=16770261#comment-16770261
> > ends with BUILD FAILURE. After fixing BUILD FAILURE error "./gradlew
> > tasks" fails with "Plugin with id 'gretty' not found." message.
> > Running "mvn jetty:run" fails with "Could not find artifact
> > javax.servlet:servlet-api:jar:3.0.1 in jboss
> > (http://repository.jboss.org/nexus/content/groups/public/)" message.
> >
> > Also in my initial idea for update quickstart could be:
> >
> > * Use Spring Boot instead Gretty?
> > * Use log4j 2 instead slf4j and logback?
> > * Provide some simple unit and integration test examples?
> > * Use more new Gradle version (ideally latest) instead of taking
> > Tapestry Gradle build version?
> >
> > I could spend some time updating quickstart and provide a patch. It
> > seems good to you?
> >
> > Regards,
> > pd
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
> --
> Thiago

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: About quickstart and TAP5-2579

pico.dev
Hi!

I have cretated this issue
https://issues.apache.org/jira/browse/TAP5-2608 to fix and update
quickstart. I attached a patch, please review and test it, any comment
is welcomed.

Regards,
pd

El jue., 21 feb. 2019 a las 21:19, pico.dev (<[hidden email]>) escribió:

>
> Great! I will be back with a patch in some days.
>
> El mié., 20 feb. 2019 a las 14:33, Thiago H. de Paula Figueiredo
> (<[hidden email]>) escribió:
> >
> > Yes! Please do it.
> >
> > On Mon, Feb 18, 2019 at 6:20 PM pico.dev <[hidden email]> wrote:
> >
> > > Hi,
> > >
> > > The quickstart project has the following issue open
> > > https://issues.apache.org/jira/browse/TAP5-2579.
> > >
> > > Running the quickstart as in comment
> > >
> > > https://issues.apache.org/jira/browse/TAP5-2579?focusedCommentId=16770261#comment-16770261
> > > ends with BUILD FAILURE. After fixing BUILD FAILURE error "./gradlew
> > > tasks" fails with "Plugin with id 'gretty' not found." message.
> > > Running "mvn jetty:run" fails with "Could not find artifact
> > > javax.servlet:servlet-api:jar:3.0.1 in jboss
> > > (http://repository.jboss.org/nexus/content/groups/public/)" message.
> > >
> > > Also in my initial idea for update quickstart could be:
> > >
> > > * Use Spring Boot instead Gretty?
> > > * Use log4j 2 instead slf4j and logback?
> > > * Provide some simple unit and integration test examples?
> > > * Use more new Gradle version (ideally latest) instead of taking
> > > Tapestry Gradle build version?
> > >
> > > I could spend some time updating quickstart and provide a patch. It
> > > seems good to you?
> > >
> > > Regards,
> > > pd
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
> > --
> > Thiago

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]