Tapestry 5.3.7 with Tanuki service wrapper

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Tapestry 5.3.7 with Tanuki service wrapper

Qbyte Consulting
Hi,

Has anyone had success running ioc via the Tanuki Service Wrapper product?

I'm having problems with Tapestry instantiating a DAO service that is
injected with EntityManager references.

Suspect a class loader problem, I'm getting inconsistent results. All works
fine from the command line launch?

Probably means this isn't a Tapestry issue, but just interested to know
anyone who's had a good result with Tanuki starting Tapestry?

John
Reply | Threaded
Open this post in threaded view
|

Re: Tapestry 5.3.7 with Tanuki service wrapper

David Taylor
We use JSW (last non-GPL version) + Jetty 9.3/Tomcat 8 + Tapestry 5.4 in
production on various flavors of Windows without issue. The only unusual
thing I have seen is a problem with HikariCP having problems locating
the jTDS driver at system startup. Very weird since the problem does not
occur if the server is manually restarted. The fix was to tell HikariCP
the fully qualified class name of the driver.

David

emailsig On 3/29/2016 3:42 AM, Qbyte Consulting wrote:

> Hi,
>
> Has anyone had success running ioc via the Tanuki Service Wrapper product?
>
> I'm having problems with Tapestry instantiating a DAO service that is
> injected with EntityManager references.
>
> Suspect a class loader problem, I'm getting inconsistent results. All works
> fine from the command line launch?
>
> Probably means this isn't a Tapestry issue, but just interested to know
> anyone who's had a good result with Tanuki starting Tapestry?
>
> John
>



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tapestry 5.3.7 with Tanuki service wrapper

Kalle Korhonen-2
I've used Tanuki to wrap various versions of Tapestry webapps and I've also
done plenty of embedded Jetty/Tomcat installations. Never had any major
issues with Tanuki. Any problems are almost always related to classloader
issues, not directly caused by Tanuki.

Kalle

On Wed, Mar 30, 2016 at 12:41 PM, David Taylor <
[hidden email]> wrote:

> We use JSW (last non-GPL version) + Jetty 9.3/Tomcat 8 + Tapestry 5.4 in
> production on various flavors of Windows without issue. The only unusual
> thing I have seen is a problem with HikariCP having problems locating the
> jTDS driver at system startup. Very weird since the problem does not occur
> if the server is manually restarted. The fix was to tell HikariCP the fully
> qualified class name of the driver.
>
> David
>
>
> emailsig On 3/29/2016 3:42 AM, Qbyte Consulting wrote:
>
>> Hi,
>>
>> Has anyone had success running ioc via the Tanuki Service Wrapper product?
>>
>> I'm having problems with Tapestry instantiating a DAO service that is
>> injected with EntityManager references.
>>
>> Suspect a class loader problem, I'm getting inconsistent results. All
>> works
>> fine from the command line launch?
>>
>> Probably means this isn't a Tapestry issue, but just interested to know
>> anyone who's had a good result with Tanuki starting Tapestry?
>>
>> John
>>
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>