Tapestry 5.4 and Hibernate version

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Tapestry 5.4 and Hibernate version

nquirynen
Hi,

All our libraries use Hibernate version 3.6.8.Final at the moment. And
we use Tapestry 5.3.7 for our main web application.
Now for a new web application I wanted to make use of Tapestry 5.4 from
the start, so I use 5.4-beta-2 now. But if I want to use
tapestry-hibernate I'm getting into trouble. I just wanted confirmation
if we have to upgrade our Hibernate version to version 4+ if we want to
make use of Tapestry 5.4?

Thanks,
Nathan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Tapestry 5.4 and Hibernate version

George Christman
Tapestry-Hibernate 5.4-beta-2 uses hibernate-core 4.1.2 by default. However
if your using mysql and tomcat you'll want to upgrade hibernate-core do to
this bug https://forum.hibernate.org/viewtopic.php?p=2454336. I created a
JIRA issue requesting hibernate to be upgraded. I'm using a newer version
of hibernate-core without issue.


On Thu, Feb 13, 2014 at 3:32 AM, Nathan Quirynen <
[hidden email]> wrote:

> Hi,
>
> All our libraries use Hibernate version 3.6.8.Final at the moment. And
> we use Tapestry 5.3.7 for our main web application.
> Now for a new web application I wanted to make use of Tapestry 5.4 from
> the start, so I use 5.4-beta-2 now. But if I want to use
> tapestry-hibernate I'm getting into trouble. I just wanted confirmation
> if we have to upgrade our Hibernate version to version 4+ if we want to
> make use of Tapestry 5.4?
>
> Thanks,
> Nathan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
George Christman
www.CarDaddy.com
P.O. Box 735
Johnstown, New York
Reply | Threaded
Open this post in threaded view
|

Re: Tapestry 5.4 and Hibernate version

balapal
I use it with hibernate 4.2.8.Final.
I have found 4.3.x to be incompatible.


On 14 February 2014 21:12, George Christman <[hidden email]> wrote:

> Tapestry-Hibernate 5.4-beta-2 uses hibernate-core 4.1.2 by default. However
> if your using mysql and tomcat you'll want to upgrade hibernate-core do to
> this bug https://forum.hibernate.org/viewtopic.php?p=2454336. I created a
> JIRA issue requesting hibernate to be upgraded. I'm using a newer version
> of hibernate-core without issue.
>
>
> On Thu, Feb 13, 2014 at 3:32 AM, Nathan Quirynen <
> [hidden email]> wrote:
>
> > Hi,
> >
> > All our libraries use Hibernate version 3.6.8.Final at the moment. And
> > we use Tapestry 5.3.7 for our main web application.
> > Now for a new web application I wanted to make use of Tapestry 5.4 from
> > the start, so I use 5.4-beta-2 now. But if I want to use
> > tapestry-hibernate I'm getting into trouble. I just wanted confirmation
> > if we have to upgrade our Hibernate version to version 4+ if we want to
> > make use of Tapestry 5.4?
> >
> > Thanks,
> > Nathan
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
>
> --
> George Christman
> www.CarDaddy.com
> P.O. Box 735
> Johnstown, New York
>
Reply | Threaded
Open this post in threaded view
|

Re: Tapestry 5.4 and Hibernate version

balapal
I forgot to add that I use tapestry-jpa, not tapestry-hibernate, so it
might work with hibernate 4.3.x


On 14 February 2014 23:17, Balázs Palcsó <[hidden email]> wrote:

> I use it with hibernate 4.2.8.Final.
> I have found 4.3.x to be incompatible.
>
>
> On 14 February 2014 21:12, George Christman <[hidden email]>wrote:
>
>> Tapestry-Hibernate 5.4-beta-2 uses hibernate-core 4.1.2 by default.
>> However
>> if your using mysql and tomcat you'll want to upgrade hibernate-core do to
>> this bug https://forum.hibernate.org/viewtopic.php?p=2454336. I created a
>> JIRA issue requesting hibernate to be upgraded. I'm using a newer version
>> of hibernate-core without issue.
>>
>>
>> On Thu, Feb 13, 2014 at 3:32 AM, Nathan Quirynen <
>> [hidden email]> wrote:
>>
>> > Hi,
>> >
>> > All our libraries use Hibernate version 3.6.8.Final at the moment. And
>> > we use Tapestry 5.3.7 for our main web application.
>> > Now for a new web application I wanted to make use of Tapestry 5.4 from
>> > the start, so I use 5.4-beta-2 now. But if I want to use
>> > tapestry-hibernate I'm getting into trouble. I just wanted confirmation
>> > if we have to upgrade our Hibernate version to version 4+ if we want to
>> > make use of Tapestry 5.4?
>> >
>> > Thanks,
>> > Nathan
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: [hidden email]
>> > For additional commands, e-mail: [hidden email]
>> >
>> >
>>
>>
>> --
>> George Christman
>> www.CarDaddy.com
>> P.O. Box 735
>> Johnstown, New York
>>
>
>