Quantcast

Tapestry5 future compatiblity?

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Tapestry5 future compatiblity?

sodium
Hi,

I am still deciding whether to choose Tapestry5 for my upcoming project. I was reading a lot how each version of Tapestry isn't backward compatible with older version and how migrating the code to new Tapestry is a nightmare. I like Tapestry declaractive model but my priority in choosing a framework is the ease of migrating to the newer version.

So is there any information on regards to whether Tapestry 6 being rehauled again ? Is this the right time to step into Tapestry or should i wait till near GA release?
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry5 future compatiblity?

Howard Lewis Ship
Just search the archives for "Tapestry 6" and see what you find.

BTW, we're about to offer a stable release of 5.1 that adds huge new
features with (near) perfect backwards compatibility.

On Wed, Apr 29, 2009 at 8:23 PM, sodium <[hidden email]> wrote:

>
> Hi,
>
> I am still deciding whether to choose Tapestry5 for my upcoming project. I
> was reading a lot how each version of Tapestry isn't backward compatible
> with older version and how migrating the code to new Tapestry is a
> nightmare. I like Tapestry declaractive model but my priority in choosing a
> framework is the ease of migrating to the newer version.
>
> So is there any information on regards to whether Tapestry 6 being rehauled
> again ? Is this the right time to step into Tapestry or should i wait till
> near GA release?
> --
> View this message in context: http://www.nabble.com/Tapestry5-future-compatiblity--tp23307803p23307803.html
> Sent from the Tapestry - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>



--
Howard M. Lewis Ship

Creator of Apache Tapestry
Director of Open Source Technology at Formos

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry5 future compatiblity?

angelochen
Hi,

That's a good news, I have a 5.0.18 app waiting for that to upgrade.

Angelo
 
Howard Lewis Ship wrote
BTW, we're about to offer a stable release of 5.1 that adds huge new
features with (near) perfect backwards compatibility.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry5 future compatiblity?

Andy Pahne-7
In reply to this post by sodium
sodium schrieb:
> Hi,
>
> I am still deciding whether to choose Tapestry5 for my upcoming project. I
> was reading a lot how each version of Tapestry isn't backward compatible
> with older version and how migrating the code to new Tapestry is a
> nightmare. I like Tapestry declaractive model but my priority in choosing a
> framework is the ease of migrating to the newer version.
>
>  

To say upgrading has been a "nightmare" would be an exaggeratuion.

My experience with several application upgrades, that I have taken part
in the past several years:

T3 -> T4  
   Was not that easy, but managable.

T4 -> T5  
  Done that for two apps. That was easy. We ended up writing some code
(component libraries) new, but that
was not that hard and time consuming, because many concepts used in T4
translate to T5 very well.


> So is there any information on regards to whether Tapestry 6 being rehauled
> again ? Is this the right time to step into Tapestry or should i wait till
> near GA release?
>  


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry5 future compatiblity?

Peter Stavrinides
> was reading a lot how each version of Tapestry isn't backward compatible
> with older version and how migrating the code to new Tapestry is a
> nightmare.
I also did the migration... developer time = money, so this is a very valid concern, but Tapestry 5 is worth it! You will gain in productivity in the long run. From 5 onwards backwards compatibility is to be maintained.

>Is this the right time to step into Tapestry or should i wait till
> near GA release?
That depends on your situation / view of course, but let me mention that we have been very pleased with Tapestry 5, running in production for at least a year now, at first on snapshots (we took the chance), and have had no show-stoppers, in fact we found Tapestry 5 in general is very stable.  

Peter




----- Original Message -----
From: "Andy Pahne" <[hidden email]>
To: "Tapestry users" <[hidden email]>
Sent: Thursday, 30 April, 2009 11:36:04 GMT +02:00 Athens, Beirut, Bucharest, Istanbul
Subject: Re: Tapestry5 future compatiblity?

sodium schrieb:
> Hi,
>
> I am still deciding whether to choose Tapestry5 for my upcoming project. I
> was reading a lot how each version of Tapestry isn't backward compatible
> with older version and how migrating the code to new Tapestry is a
> nightmare. I like Tapestry declaractive model but my priority in choosing a
> framework is the ease of migrating to the newer version.
>
>  

To say upgrading has been a "nightmare" would be an exaggeratuion.

My experience with several application upgrades, that I have taken part
in the past several years:

T3 -> T4  
   Was not that easy, but managable.

T4 -> T5  
  Done that for two apps. That was easy. We ended up writing some code
(component libraries) new, but that
was not that hard and time consuming, because many concepts used in T4
translate to T5 very well.


> So is there any information on regards to whether Tapestry 6 being rehauled
> again ? Is this the right time to step into Tapestry or should i wait till
> near GA release?
>  


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry5 future compatiblity?

Bryan Lewis-5
In reply to this post by Andy Pahne-7
That agrees well with my T3-4-5 experience over the last five years.  Once I
committed to T5, it wasn't as bad as I'd feared from all the mailing-list
discussion. (Note to self:  The list is mainly about problems.)  It felt
familiar, the "concepts translated well".

Getting accustomed to Maven and Jetty (both new to me) was more of a hump
than Tapestry.  The quick-start tutorial worked well... getting that first
page running is a big help.


On Thu, Apr 30, 2009 at 4:36 AM, Andy Pahne <[hidden email]> wrote:

> To say upgrading has been a "nightmare" would be an exaggeratuion.
>
> My experience with several application upgrades, that I have taken part in
> the past several years:
>
> T3 -> T4    Was not that easy, but managable.
>
> T4 -> T5    Done that for two apps. That was easy. We ended up writing some
> code (component libraries) new, but that
> was not that hard and time consuming, because many concepts used in T4
> translate to T5 very well.
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: Tapestry5 future compatiblity?

AndyB
In reply to this post by sodium
> I am still deciding whether to choose Tapestry5 for my upcoming
> project. I
> was reading a lot how each version of Tapestry isn't backward
> compatible
> with older version and how migrating the code to new Tapestry is a
> nightmare. I like Tapestry declaractive model but my priority in
> choosing a
> framework is the ease of migrating to the newer version.

I recently migrated our application from 5.0 to 5.1 and it was mostly seamless. The issues were mostly bugs, which considering I was migrating to a pre-release version of 5.1 that's to be expected. It was worth it for the new stuff to us, and it also helped get 5.1 GA ready. (very close now I think) This app has had 9 developers working for a year so there's a lot there to migrate.
 
> So is there any information on regards to whether Tapestry 6 being
> rehauled
> again ? Is this the right time to step into Tapestry or should i wait
> till
> near GA release?

Tapestry 6 is not planned by Howard at all and I don't ever see the need for it. I would get the latest beta of T5.1 and jump right in. It's in a pretty solid state now.

Cheers,

Andy.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Tapestry5 future compatiblity?

sodium
In reply to this post by sodium
Thanks a lot for all the input folks. Putting aside my doubt for future compatiblity for now, I think i might give Tapestry5 a try cause i found it to be pretty straight forward especially when i come from J2EE, and Jboss seam background.

And to say that i remember reading somewhere how Tapestry community isn't active is such an understatement indeed. Howard himself is even the first person to reply to this thread, i am impressed.
Loading...