Upgrade selenium?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Upgrade selenium?

bobharner
Hi devs,

Correct me if I'm wrong on this, but I believe the current Tapestry
integration tests use Selenium version 2.46.0, which doesn't support
any recent version of Firefox. By contrast, Selenium 2.52.0 supports
recent Firefox versions but requires Java 7 or newer. Since we're
dropping support for Java 6 anyway, is there any reason not to upgrade
to the latest Selenium? Or is there something I'm forgetting? Maybe
there's still a Firefox version problem on the ci server?

I just ran all the Tapestry tests with Selenium upgraded to 2.52.0 and
using JDK 1.8.0_40 with no errors. I haven't tried the same with JDK
1.7 yet but it should work too.

Bob Harner

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Upgrade selenium?

Jochen Kemnade-3
Hi,

Am 22.02.2016 um 04:16 schrieb Bob Harner:
> Correct me if I'm wrong on this, but I believe the current Tapestry
> integration tests use Selenium version 2.46.0, which doesn't support
> any recent version of Firefox.

Correct.

> By contrast, Selenium 2.52.0 supports recent Firefox versions but requires Java 7 or newer.

Also correct.

> Since we're dropping support for Java 6 anyway, is there any reason not to upgrade
> to the latest Selenium?

We just haven't made the switch to Java 7 or 8 or whatever yet. I
currently don't want to maintain two branches, that's why I didn't
create a 5.4 release branch yet.
If someone steps up to take care of the 5.4 branch and of backporting
bugfix commits from master, I'd branch and concentrate on working toward
a 5.5 release in master.

Jochen

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]