strange issue with Eclipse + Tomcat (solved)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

strange issue with Eclipse + Tomcat (solved)

Ivano Luberti
Today I got lost for a few hours trying to solve the following issue.
Since I couldn't find anything googling I thought it worth to spend a
few minutes to write it on the list.

I use Tomcat+Eclipse on a Windows box to develop
To achieve auto-reloading I set the "Serve modules without publishing"
option while developing.

Today I deployed my application on a customer server and after loading
the first page correctly I kept getting the following exception on the
second one

org.apache.tapestry5.ioc.internal.OperationException
Embedded component(s) barCodeForm are defined within component class
it.archicoop.met.obliterazione.pages.BarCode (or a super-class of
BarCode), but are not present in the component template (null).

So clearly Tapestry was not able to load the tml file: but why?
Well of course there was a mistake by me:
I have

BarCode.java

but

Barcode.tml

what of course was misleding me was the fact that I had been able to
develop without issues but when deploying  I hit this kind of issue.
Finally I discovered that also on the dev (windows ) machine, removing
the flag for the "Serve modules without publishing" option causes the issue.

Or better said using "Serve modules without publishing" option Tomcat
seems to be not case sensitive on file names.

Hope this message can save time to someone someday






 

--
==================================================
dott. Ivano Mario Luberti
Archimede Informatica societa' cooperativa a r. l.
Sede Operativa
Via Gereschi 36 - 56126- Pisa
tel.: +39-050- 580959
tel/fax: +39-050-9711344
web: www.archicoop.it
==================================================



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]